<< Reserved characters in WebSphere Application Server passwords... Really!? | Home | Fake names >>

Configuring Eclipse Neon on Windows 10 64 bit for Notes plugin development

A member of the community reached out to me yesterday to ask whether I recognized a specific error message he was encountering trying to make Eclipse launch Notes 9 correctly for plugin development. I came back with a few suggestions but as I hadn't tried on Windows 10 yet I really couldn't offer much help. This morning I tried configuring Notes 9.0.1 for plugin development on Windows 10 and it went smoothly. Here are the steps I took:

  1. Download Eclipse Neon for RCP and RAP development bundle for Windows 64 bit
  2. Unzip bundle and launch Eclipse
  3. Follow the steps described in my Configure Eclipse 4.2 for Notes 9 post
  4. When configuring variables I used the following values:
    • install_id: 1460097942140
    • rcp.base_version: 9.0.1_20131002-1404
    • rcp.home as described in above post
That's it really...



Avatar: Ralf M Petter

Re: Configuring Eclipse Neon on Windows 10 64 bit for Notes plugin development

Do you have tried this with or without Fixpacks installed for the Notes clients. I had some problems in the past to get it running with installed Fixpacks because Eclipse selects the wrong version of Notes plugins for the target platform. So i have to do some changes in the plugins to start section of the launch configuration to get it running..

Avatar: Mikkel Flindt Heisterberg

Re: Configuring Eclipse Neon on Windows 10 64 bit for Notes plugin development

The issue I've seen is that Notes is pretty bad at leaving old versions of plugins behind so you have to manually remove the old plugins from the target plaform in Eclipse. May be related.


Add a comment Send a TrackBack