<< Question on LotusScript.doc HTML output | Home | JarPlug Eclipse plug-in >>

Installing Lotus Expeditor Toolkit 6.2 - there's an issue with the instructions

In preparation for my Lotusphere session I installed Lotus Expeditor toolkit 6.2 on top of a clean Eclipse 3.4 install in order to test it out. One of the things I noticed was that there is an error in the install guidelines - not critical but if you're new to Eclipse you might be stumped. The documentation also fails to mention how to configure the Toolkit once installed. Read on...

The error is in the doc/index.html in step 5 where it states

"Select Add Site and browse to the drive 
and directory where the Lotus Expeditor 
Toolkit update site zip file is located 
and click OK."
The problem is that the Expeditor toolkit that I downloaded from IBM Partnerworld didn't have a zip-file but instead an unpacked update site. In my case step 5 should instead be
"Select Add Site and browse to the drive 
and directory where you unpacked the Lotus 
Expeditor Toolkit and select the 
Expeditor_Toolkit_install directory and 
click OK."
The remaining steps are fine and installing the toolkit is almost easy... There is one caveat the documentation fails to mention and that's how to fill in the dialog that pops up once the Toolkit has been installed and Eclipse has been restarted. I fill in the dialog as follows (with Notes 8.5 installed in C:\Program Files\Notes 8):
  • Lotus Notes 8
  • C:\Program Files\Notes8\framework\rcp\eclipse
  • jre6
  • 1.5
  • Display the first time a new workspace opens



Avatar: Jeff Gilfelt

Re: Installing Lotus Expeditor Toolkit 6.2 - there's an issue with the instructions

I haven't installed this yet, but I'm assuming that there is backward compatibility here, and you can target XPD 6.1 based configurations like Notes 8.0.x with the 6.2 toolkit?
Avatar: Mikkel Heisterberg

Re: Installing Lotus Expeditor Toolkit 6.2 - there's an issue with the instructions

Yes there is. Most important though is that you familiarize yourself with the compilation options to make sure your code works across the different versions (Notes 8.0.x is Java 5 and Notes 8.5.x is Java 6). See this post for more info: http://lekkimworld.com/2008/08/07/show_n_tell_thursday_cross_compiling_sidebar_plugins_for_notes_8_0_x_and_notes_8_5_7_august_2008.html
Avatar: Greg Bruesch

Re: Installing Lotus Expeditor Toolkit 6.2 - there's an issue with the instructions

Just a quick question and comment. 

Question first :- Are you running Vista or XP for your development machine?

I know you have mentioned your setups in the past, but I had all sorts of issues getting Eclipse + WTP, Expeditor to work in Notes 8.5 on my Dell Vista laptop.  I spent a full day trying differnent installations (using your instructions and those on the Expeditor Wiki) but to no avail. Frustrated, on the following day I grabbed my older laptop with XP and reinstalled all first time and all worked okay. 

Anyway great blog, keep up the good work.
Avatar: Mikkel Heisterberg

Re: Installing Lotus Expeditor Toolkit 6.2 - there's an issue with the instructions

Vista but I wouldn't think it mattered as the problem is with the documentation rather than anything else. Thank you for the nice words.
Avatar: Ian Scott

Re: Installing Lotus Expeditor Toolkit 6.2 - there's an issue with the instructions

Mikkel,

Many thanks for this. I figured out the install piece but have been hitting 'cancel' when presented with the dialog box.

As per Greg's comment, in recent months this has become a must read blog for me. I've only just started dipping my toes into the Java/Eclipse world but I know I have to get immersed and this blog has helped me make progress I know I would never otherwise have made. I appreciate it.

Add a comment Send a TrackBack