<< Temporary solution to broken Domino Web Access in Firefox 1.5 | Home | Making changes to the OpenLog application >>

You want Members with your catalog?

Well I guess there is a reason why one of the first questions you ask in these kinds of situations is: "Did you recently change anything?" They told me that they had changed the path to the directory in their directory catalog configuration document since the specified path was wrong. Aha! A clue. The problem would probably have something to do with the directory catalog configuration.

After a rebuild of the directory catalog (load dircat dircat.nsf -r) without errors i checked one of the group documents in the directory catalog - it was empty. I checked the configuration document and saw that the list of fields to include didn't mention the "Members" field. As mentioned in the help this is fine if the directory catalog is for mobile users since group expansion is done of the server. Here however, the directory catalog is on the server and is specified in the server document so the Domino server uses it to address e-mail.

This explained why no Non-delivery report was sent and why e-mail appeared to simply disappear. From the perspective of the Domino server the group was valid but was empty.

After adding the "Members" field to the list of fields to include and rebuilding the directory catalog yet again it worked. For some reason the wrong path to the directory combined with the error in the configuration document had masked the error.

Mental note to self: "Always make sure the Members field is included in server-side directory catalogs."